1.3.8 / February 28, 2019
(4.3/5) (3692)
Loading...

Description

Livescore Soccer worldwide live football/socer scores FEATURES -Live scores worldwide - Detailed match information - Live leaguetables - User friendly - Very fast and responsive even on slowconnection - Minimal data transfers - Lightweight

App Information Livescore Soccer

  • App Name
    Livescore Soccer
  • Package Name
    com.kvartsoft.livescorefootball
  • Updated
    February 28, 2019
  • File Size
    2.0M
  • Requires Android
    Android 4.0 and up
  • Version
    1.3.8
  • Developer
    Kvart Soft
  • Installs
    500,000+
  • Price
    Free
  • Category
    Sports
  • Developer
  • Google Play Link

Livescore Soccer Version History

Select Livescore Soccer Version :
  • 1.3.8 (38) - Latest Version
  • 1.3.6 (36)
  • Livescore Soccer 1.3.8 APK File

    Publish Date: 2019 /10/30
    Requires Android: Android 4.0+ (Ice Cream Sandwich, API: 14)
    File Size: 2.1 MB
    Tested on: Android 8.0 (Oreo, API: 26)
    File Sha1: 67ee8a9bb20472b0956289d2a435bb65ebb8157f
    APK Signature: 03f679705d8967188f61697a355001aaabf276d2
  • Livescore Soccer 1.3.6 APK File

    Publish Date: 2017 /1/13
    Requires Android: Android 2.3+ (Gingerbread, API: 9)
    File Size: 2.2 MB
    Tested on: Android 4.2 (Jelly Bean, API: 17)
    File Sha1: 3b9d67ad67bbdd9f04aa8dcb57af0ab109243b5b
    APK Signature: 03f679705d8967188f61697a355001aaabf276d2

Kvart Soft Show More...

Livescore Soccer 1.3.8 APK
Kvart Soft
Livescore Soccer worldwide live football/socer scores FEATURES -Live scores worldwide - Detailed match information - Live leaguetables - User friendly - Very fast and responsive even on slowconnection - Minimal data transfers - Lightweight
Score Center 1.1.5 APK
Kvart Soft
Score Center brings you live scores for NBANFL MLB NHLFEATURES- Live scores NBA NFL MLB NHL- Detailed match information- Live league tables- Select your own refresh period- User friendly- Very fast and responsive even on slow connection- Minimal data transfers- Lightweight- FreeREQUIREMENTSAndroid 2.2 (or higher) required.
Loading...